aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 7af2bb5..c1a017c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -59,6 +59,11 @@
#boot.kernelPackages = pkgs.linuxKernel.packages.linux_rpi3;
})
];};
+ beagleboneSystem = genericSystem {system = "armv7l-linux"; extra_modules = [
+ nixturris.nixosModules.turris-crossbuild
+ nixturris.nixosModules.armv7l-overlay
+ # TODO
+ ];};
turrisSystem = board: hostname: {
${hostname} = nixturris.lib.nixturrisSystem {
@@ -79,6 +84,7 @@
amd64System "susan" //
raspi2System "spt-mpd" //
raspi3System "adm-mpd" //
+ beagleboneSystem "gaspode" //
turrisMoxSystem "dean" //
turrisOmniaSystem "spt-omnia" //
turrisMoxSystem "spt-mox" //