aboutsummaryrefslogtreecommitdiff
path: root/develop/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'develop/default.nix')
-rw-r--r--develop/default.nix15
1 files changed, 13 insertions, 2 deletions
diff --git a/develop/default.nix b/develop/default.nix
index 5f880dc..421250f 100644
--- a/develop/default.nix
+++ b/develop/default.nix
@@ -1,5 +1,16 @@
-{ nixpkgs, shellrc, system }: {
+{ nixpkgs, shellrc, system }:
+let
- riscv = import ./riscv.nix { inherit nixpkgs; inherit shellrc; inherit system; };
+ callDevelop = file: import file {
+ inherit nixpkgs;
+ inherit shellrc;
+ inherit system;
+ };
+
+in {
+
+ armv6 = callDevelop ./nuttx.nix "armv6-m";
+ armv7e = callDevelop ./nuttx.nix "armv7e-m";
+ riscv = callDevelop ./riscv.nix;
}