aboutsummaryrefslogtreecommitdiff
path: root/devShells/riscv.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/riscv.nix')
-rw-r--r--devShells/riscv.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/devShells/riscv.nix b/devShells/riscv.nix
index e9e33ef..0bcacb4 100644
--- a/devShells/riscv.nix
+++ b/devShells/riscv.nix
@@ -2,8 +2,7 @@
, default, c
}:
let
- pkgs = nixpkgs.legacyPackages.${system};
- pkgs-riscv = import nixpkgs.outPath {
+ pkgs = import nixpkgs.outPath {
localSystem = system;
crossSystem = {
config = "riscv32-none-elf";
@@ -15,11 +14,10 @@ let
};
in pkgs.mkShell {
- packages = (with pkgs; [
+ packages = with pkgs.buildPackages; [
qtrvsim
- ]) ++ (with pkgs-riscv.buildPackages; [
gcc pkg-config
- ]);
+ ];
inputsFrom = [ default c ];
meta.platforms = nixpkgs.lib.platforms.linux;
}