aboutsummaryrefslogtreecommitdiff
path: root/devShells/riscv.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-10-06 10:56:42 +0200
committerKarel Kočí <cynerd@email.cz>2022-10-06 10:56:42 +0200
commit507252f378872f2b14751dc800fe5f1606c404b4 (patch)
treea75cd13b3448f3b5878f7bb5ec37e400a8b4c854 /devShells/riscv.nix
parent33067a7e9bdb84521100fdb770ddf426c2a895f2 (diff)
downloadnixos-personal-507252f378872f2b14751dc800fe5f1606c404b4.tar.gz
nixos-personal-507252f378872f2b14751dc800fe5f1606c404b4.tar.bz2
nixos-personal-507252f378872f2b14751dc800fe5f1606c404b4.zip
devShells: tweak syntax and add czmq and libevent
Diffstat (limited to 'devShells/riscv.nix')
-rw-r--r--devShells/riscv.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/devShells/riscv.nix b/devShells/riscv.nix
index e9e33ef..0bcacb4 100644
--- a/devShells/riscv.nix
+++ b/devShells/riscv.nix
@@ -2,8 +2,7 @@
, default, c
}:
let
- pkgs = nixpkgs.legacyPackages.${system};
- pkgs-riscv = import nixpkgs.outPath {
+ pkgs = import nixpkgs.outPath {
localSystem = system;
crossSystem = {
config = "riscv32-none-elf";
@@ -15,11 +14,10 @@ let
};
in pkgs.mkShell {
- packages = (with pkgs; [
+ packages = with pkgs.buildPackages; [
qtrvsim
- ]) ++ (with pkgs-riscv.buildPackages; [
gcc pkg-config
- ]);
+ ];
inputsFrom = [ default c ];
meta.platforms = nixpkgs.lib.platforms.linux;
}