aboutsummaryrefslogtreecommitdiff
path: root/devShells/qt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/qt.nix')
-rw-r--r--devShells/qt.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/devShells/qt.nix b/devShells/qt.nix
index b6450eb..80b83b5 100644
--- a/devShells/qt.nix
+++ b/devShells/qt.nix
@@ -9,12 +9,16 @@ in
pkgs.mkShell {
packages = with pkgs;
with libsForQt5; [
+ #full
qtbase
qtserialport
qtwebsockets
doctest
+ qtcharts
+ qtwayland
- (qcoro.overrideAttrs (oldAttrs: {
+ (stdenv.mkDerivation {
+ pname = "qcoro";
version = "0.6.1";
src = fetchFromGitHub {
owner = "danvratil";
@@ -22,8 +26,9 @@ in
rev = "261663560f59a162c0c82158a6cde41089668871";
sha256 = "OAYJpoW3b0boSYBfuzLrFvlYSmP3SON8O6HsDQoi+I8=";
};
- buildInputs = oldAttrs.buildInputs ++ [qt5.qtbase];
- }))
+ buildInputs = [qtbase qtwebsockets];
+ nativeBuildInputs = [wrapQtAppsHook cmake];
+ })
];
inputsFrom = with pkgs; [default c];
meta.platforms = ["x86_64-linux"];