aboutsummaryrefslogtreecommitdiff
path: root/devShells/qt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/qt.nix')
-rw-r--r--devShells/qt.nix53
1 files changed, 28 insertions, 25 deletions
diff --git a/devShells/qt.nix b/devShells/qt.nix
index caf9b99..b6450eb 100644
--- a/devShells/qt.nix
+++ b/devShells/qt.nix
@@ -1,27 +1,30 @@
-{ system, nixpkgs
-, default, c
-}:
-let
+{
+ system,
+ nixpkgs,
+ default,
+ c,
+}: let
pkgs = nixpkgs.legacyPackages.${system};
+in
+ pkgs.mkShell {
+ packages = with pkgs;
+ with libsForQt5; [
+ qtbase
+ qtserialport
+ qtwebsockets
+ doctest
-in pkgs.mkShell {
- packages = (with pkgs; with libsForQt5; [
- qtbase
- qtserialport
- qtwebsockets
- doctest
-
- (qcoro.overrideAttrs (oldAttrs: {
- version = "0.6.1";
- src = fetchFromGitHub {
- owner = "danvratil";
- repo = "qcoro";
- rev = "261663560f59a162c0c82158a6cde41089668871";
- sha256 = "OAYJpoW3b0boSYBfuzLrFvlYSmP3SON8O6HsDQoi+I8=";
- };
- buildInputs = oldAttrs.buildInputs ++ [qt5.qtbase];
- }))
- ]);
- inputsFrom = with pkgs; [ default c ];
- meta.platforms = ["x86_64-linux"];
-}
+ (qcoro.overrideAttrs (oldAttrs: {
+ version = "0.6.1";
+ src = fetchFromGitHub {
+ owner = "danvratil";
+ repo = "qcoro";
+ rev = "261663560f59a162c0c82158a6cde41089668871";
+ sha256 = "OAYJpoW3b0boSYBfuzLrFvlYSmP3SON8O6HsDQoi+I8=";
+ };
+ buildInputs = oldAttrs.buildInputs ++ [qt5.qtbase];
+ }))
+ ];
+ inputsFrom = with pkgs; [default c];
+ meta.platforms = ["x86_64-linux"];
+ }