aboutsummaryrefslogtreecommitdiff
path: root/devShells/qt.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/qt.nix')
-rw-r--r--devShells/qt.nix35
1 files changed, 16 insertions, 19 deletions
diff --git a/devShells/qt.nix b/devShells/qt.nix
index eb9d3e9..2070009 100644
--- a/devShells/qt.nix
+++ b/devShells/qt.nix
@@ -1,22 +1,19 @@
{
- system,
- nixpkgs,
+ pkgs,
default,
c,
-}: let
- pkgs = nixpkgs.legacyPackages.${system};
-in
- pkgs.mkShell {
- packages = with pkgs;
- with libsForQt5; [
- qtbase
- qttranslations
- qtserialport
- qtwebsockets
- doctest
- qtcharts
- qtwayland
- ];
- inputsFrom = with pkgs; [default c];
- meta.platforms = ["x86_64-linux"];
- }
+}:
+pkgs.mkShell {
+ packages = with pkgs;
+ with libsForQt5; [
+ qtbase
+ qttranslations
+ qtserialport
+ qtwebsockets
+ doctest
+ qtcharts
+ qtwayland
+ ];
+ inputsFrom = with pkgs; [default c];
+ meta.platforms = pkgs.lib.platforms.linux;
+}