aboutsummaryrefslogtreecommitdiff
path: root/devShells/python.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/python.nix')
-rw-r--r--devShells/python.nix109
1 files changed, 53 insertions, 56 deletions
diff --git a/devShells/python.nix b/devShells/python.nix
index 570840d..d0a40b5 100644
--- a/devShells/python.nix
+++ b/devShells/python.nix
@@ -1,58 +1,55 @@
{
- system,
- nixpkgs,
+ pkgs,
default,
-}: let
- pkgs = nixpkgs.legacyPackages.${system};
-in
- pkgs.mkShell {
- packages = with pkgs; [
- (python3.withPackages (pypkgs:
- with pypkgs; [
- ipython
-
- pytest
- pytest-html
- pytest-tap
- coverage
- python-lsp-black
- pylint
- pydocstyle
- mypy
-
- pygraphviz
- matplotlib
-
- python-gitlab
- PyGithub
-
- schema
- jinja2
- ruamel-yaml
- msgpack
- urllib3
-
- influxdb-client
- psycopg
- paho-mqtt
-
- humanize
- rich
-
- pygobject3
-
- pyserial
- pylibftdi
- pylxd
- selenium
- ]))
- geckodriver
- chromedriver
-
- gobject-introspection
- gtk3
- gtk4
- ];
- inputsFrom = with pkgs; [default];
- meta.platforms = nixpkgs.lib.platforms.linux;
- }
+}:
+pkgs.mkShell {
+ packages = with pkgs; [
+ (python3.withPackages (pypkgs:
+ with pypkgs; [
+ ipython
+
+ pytest
+ pytest-html
+ pytest-tap
+ coverage
+ python-lsp-black
+ pylint
+ pydocstyle
+ mypy
+
+ pygraphviz
+ matplotlib
+
+ python-gitlab
+ PyGithub
+
+ schema
+ jinja2
+ ruamel-yaml
+ msgpack
+ urllib3
+
+ influxdb-client
+ psycopg
+ paho-mqtt
+
+ humanize
+ rich
+
+ pygobject3
+
+ pyserial
+ pylibftdi
+ pylxd
+ selenium
+ ]))
+ geckodriver
+ chromedriver
+
+ gobject-introspection
+ gtk3
+ gtk4
+ ];
+ inputsFrom = with pkgs; [default];
+ meta.platforms = pkgs.lib.platforms.linux;
+}