aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
index 03f51f9..ef6e632 100644
--- a/devShells/nuttx.nix
+++ b/devShells/nuttx.nix
@@ -8,7 +8,7 @@ let
pkgs = import nixpkgs.outPath {
localSystem = system;
crossSystem = {
- config = if (match "armv.*" arch != null) then
+ config = if (hasPrefix "armv" arch) then
"arm-none-eabi" + (optionalString (fpu != null) "hf")
else "riscv32-none-elf";
libc = "newlib";
@@ -23,7 +23,7 @@ in pkgs.buildPackages.mkShell {
kconfig-frontends genromfs xxd
openocd
gcc gdb
- ] ++ (optionals (match "rv32.*" arch != null) [
+ ] ++ (optionals (hasPrefix "rv32" arch) [
esptool
]);
inputsFrom = [ default c ];