aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix7
1 files changed, 2 insertions, 5 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
index 506ea12..97675e9 100644
--- a/devShells/nuttx.nix
+++ b/devShells/nuttx.nix
@@ -1,7 +1,4 @@
-{
- pkgs,
- default,
- c,
+pkgs: c: {
arch,
fpu ? null,
}:
@@ -36,6 +33,6 @@ in
++ (optionals (hasPrefix "rv32" arch) [
esptool
]);
- inputsFrom = [default c];
+ inputsFrom = [c];
meta.platforms = pkgsCross.lib.platforms.linux;
}