aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix12
1 files changed, 5 insertions, 7 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
index 40172f0..0105fe5 100644
--- a/devShells/nuttx.nix
+++ b/devShells/nuttx.nix
@@ -1,5 +1,7 @@
-{ system, nixpkgs, default }:
-{ arch, fpu ? null }:
+{ system, nixpkgs
+, default, c
+, arch, fpu ? null
+}:
with nixpkgs.lib;
let
pkgs = nixpkgs.legacyPackages.${system};
@@ -18,13 +20,9 @@ in pkgs.mkShell {
packages = (with pkgs; [
kconfig-frontends genromfs xxd
openocd
-
- gnumake bear
- meson ninja
- cmake
]) ++ (with pkgs-cross.buildPackages; [
gcc gdb
]);
- inputsFrom = [ default ];
+ inputsFrom = [ default c ];
meta.platforms = nixpkgs.lib.platforms.linux;
}