aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
index 0246ad2..03f51f9 100644
--- a/devShells/nuttx.nix
+++ b/devShells/nuttx.nix
@@ -2,12 +2,15 @@
, default, c
, arch, fpu ? null
}:
+with builtins;
with nixpkgs.lib;
let
pkgs = import nixpkgs.outPath {
localSystem = system;
crossSystem = {
- config = "arm-none-eabi" + (optionalString (fpu != null) "hf");
+ config = if (match "armv.*" arch != null) then
+ "arm-none-eabi" + (optionalString (fpu != null) "hf")
+ else "riscv32-none-elf";
libc = "newlib";
gcc = {
arch = arch;
@@ -20,7 +23,9 @@ in pkgs.buildPackages.mkShell {
kconfig-frontends genromfs xxd
openocd
gcc gdb
- ];
+ ] ++ (optionals (match "rv32.*" arch != null) [
+ esptool
+ ]);
inputsFrom = [ default c ];
meta.platforms = nixpkgs.lib.platforms.linux;
}