aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
index 0105fe5..145df61 100644
--- a/devShells/nuttx.nix
+++ b/devShells/nuttx.nix
@@ -4,8 +4,7 @@
}:
with nixpkgs.lib;
let
- pkgs = nixpkgs.legacyPackages.${system};
- pkgs-cross = import nixpkgs.outPath {
+ pkgs = import nixpkgs.outPath {
localSystem = system;
crossSystem = {
config = "arm-none-eabi" + (optionalString (fpu != null) "hf");
@@ -17,12 +16,11 @@ let
};
in pkgs.mkShell {
- packages = (with pkgs; [
+ packages = with pkgs.buildPackages; [
kconfig-frontends genromfs xxd
openocd
- ]) ++ (with pkgs-cross.buildPackages; [
gcc gdb
- ]);
+ ];
inputsFrom = [ default c ];
meta.platforms = nixpkgs.lib.platforms.linux;
}