aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-10-06 10:56:42 +0200
committerKarel Kočí <cynerd@email.cz>2022-10-06 10:56:42 +0200
commit507252f378872f2b14751dc800fe5f1606c404b4 (patch)
treea75cd13b3448f3b5878f7bb5ec37e400a8b4c854 /devShells/nuttx.nix
parent33067a7e9bdb84521100fdb770ddf426c2a895f2 (diff)
downloadnixos-personal-507252f378872f2b14751dc800fe5f1606c404b4.tar.gz
nixos-personal-507252f378872f2b14751dc800fe5f1606c404b4.tar.bz2
nixos-personal-507252f378872f2b14751dc800fe5f1606c404b4.zip
devShells: tweak syntax and add czmq and libevent
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix8
1 files changed, 3 insertions, 5 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
index 0105fe5..145df61 100644
--- a/devShells/nuttx.nix
+++ b/devShells/nuttx.nix
@@ -4,8 +4,7 @@
}:
with nixpkgs.lib;
let
- pkgs = nixpkgs.legacyPackages.${system};
- pkgs-cross = import nixpkgs.outPath {
+ pkgs = import nixpkgs.outPath {
localSystem = system;
crossSystem = {
config = "arm-none-eabi" + (optionalString (fpu != null) "hf");
@@ -17,12 +16,11 @@ let
};
in pkgs.mkShell {
- packages = (with pkgs; [
+ packages = with pkgs.buildPackages; [
kconfig-frontends genromfs xxd
openocd
- ]) ++ (with pkgs-cross.buildPackages; [
gcc gdb
- ]);
+ ];
inputsFrom = [ default c ];
meta.platforms = nixpkgs.lib.platforms.linux;
}