aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
new file mode 100644
index 0000000..3066997
--- /dev/null
+++ b/devShells/nuttx.nix
@@ -0,0 +1,23 @@
+{ nixpkgs, shellrc, system }: arch:
+let
+ pkgs = nixpkgs.legacyPackages.${system};
+ pkgs-riscv = import nixpkgs.outPath {
+ localSystem = system;
+ crossSystem = {
+ config = "arm-none-eabi";
+ libc = "newlib";
+ gcc = {
+ arch = arch;
+ };
+ };
+ };
+
+in pkgs.mkShell {
+ packages = (with pkgs; [
+ kconfig-frontends
+ ]) ++ (with pkgs-riscv.buildPackages; [
+ gcc gdb
+ ]);
+ inputsFrom = [ shellrc.packages.${system}.default ];
+ meta.platforms = nixpkgs.lib.platforms.linux;
+}