aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix38
1 files changed, 0 insertions, 38 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
deleted file mode 100644
index 97675e9..0000000
--- a/devShells/nuttx.nix
+++ /dev/null
@@ -1,38 +0,0 @@
-pkgs: c: {
- arch,
- fpu ? null,
-}:
-with builtins;
-with pkgs.lib; let
- pkgsCross = import pkgs.path {
- localSystem = pkgs.buildPlatform.system;
- crossSystem = {
- config =
- if (hasPrefix "armv" arch)
- then "arm-none-eabi" + (optionalString (fpu != null) "hf")
- else "riscv32-none-elf";
- libc = "newlib";
- gcc =
- {
- inherit arch;
- }
- // (optionalAttrs (fpu != null) {inherit fpu;});
- };
- };
-in
- pkgsCross.buildPackages.mkShell {
- packages = with pkgsCross.buildPackages;
- [
- kconfig-frontends
- genromfs
- xxd
- openocd
- gcc
- gdb
- ]
- ++ (optionals (hasPrefix "rv32" arch) [
- esptool
- ]);
- inputsFrom = [c];
- meta.platforms = pkgsCross.lib.platforms.linux;
- }