aboutsummaryrefslogtreecommitdiff
path: root/devShells/nuttx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/nuttx.nix')
-rw-r--r--devShells/nuttx.nix11
1 files changed, 7 insertions, 4 deletions
diff --git a/devShells/nuttx.nix b/devShells/nuttx.nix
index 04a057d..ed0b971 100644
--- a/devShells/nuttx.nix
+++ b/devShells/nuttx.nix
@@ -1,20 +1,23 @@
-{ nixpkgs, shellrc, system }: arch:
+{ nixpkgs, shellrc, system }:
+{ arch, fpu ? null }:
+with nixpkgs.lib;
let
pkgs = nixpkgs.legacyPackages.${system};
pkgs-riscv = import nixpkgs.outPath {
localSystem = system;
crossSystem = {
- config = "arm-none-eabi";
+ config = "arm-none-eabi" + (optionalString (fpu != null) "hf");
libc = "newlib";
gcc = {
arch = arch;
- };
+ } // (optionalAttrs (fpu != null) { fpu = fpu; });
};
};
in pkgs.mkShell {
packages = (with pkgs; [
- kconfig-frontends make cmake
+ kconfig-frontends gnumake cmake
+ openocd
]) ++ (with pkgs-riscv.buildPackages; [
gcc gdb
]);