aboutsummaryrefslogtreecommitdiff
path: root/devShells/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/default.nix')
-rw-r--r--devShells/default.nix30
1 files changed, 18 insertions, 12 deletions
diff --git a/devShells/default.nix b/devShells/default.nix
index 1e8dee3..88d3638 100644
--- a/devShells/default.nix
+++ b/devShells/default.nix
@@ -1,22 +1,28 @@
-{ nixpkgs, shellrc, system }:
-let
-
+{
+ nixpkgs,
+ shellrc,
+ system,
+}: let
callDevelop = nixpkgs.lib.callPackageWith ({
inherit system;
inherit nixpkgs;
- } // shells);
+ }
+ // shells);
shells = {
default = nixpkgs.legacyPackages.${system}.mkShell {
- inputsFrom = [ shellrc.packages.${system}.default ];
+ inputsFrom = [shellrc.packages.${system}.default];
};
- armv6 = callDevelop ./nuttx.nix { arch = "armv6s-m"; };
- armv7e = callDevelop ./nuttx.nix { arch = "armv7e-m"; fpu = "vfpv3-d16"; };
- espc = callDevelop ./nuttx.nix { arch = "rv32imc"; };
- c = callDevelop ./c.nix { };
- qt = callDevelop ./qt.nix { };
+ armv6 = callDevelop ./nuttx.nix {arch = "armv6s-m";};
+ armv7e = callDevelop ./nuttx.nix {
+ arch = "armv7e-m";
+ fpu = "vfpv3-d16";
+ };
+ espc = callDevelop ./nuttx.nix {arch = "rv32imc";};
+ c = callDevelop ./c.nix {};
+ qt = callDevelop ./qt.nix {};
#riscv = callDevelop ./riscv.nix { };
};
-
-in shells
+in
+ shells