aboutsummaryrefslogtreecommitdiff
path: root/devShells/c.nix
diff options
context:
space:
mode:
Diffstat (limited to 'devShells/c.nix')
-rw-r--r--devShells/c.nix77
1 files changed, 46 insertions, 31 deletions
diff --git a/devShells/c.nix b/devShells/c.nix
index d015cb4..7aba33f 100644
--- a/devShells/c.nix
+++ b/devShells/c.nix
@@ -1,37 +1,52 @@
-{ system, nixpkgs
-, default
-}:
-let
+{
+ system,
+ nixpkgs,
+ default,
+}: let
pkgs = nixpkgs.legacyPackages.${system};
+in
+ pkgs.mkShell {
+ packages = with pkgs; [
+ clang-tools_14
+ ctags
+ gcc
+ gdb
+ pkg-config
-in pkgs.mkShell {
- packages = (with pkgs; [
+ gnumake
+ bear
+ meson
+ ninja
+ cmake
- clang-tools_14 ctags
- gcc gdb pkg-config
+ valgrind
+ lcov
+ massif-visualizer
+ cppcheck
+ flawfinder
- gnumake bear
- meson ninja
- cmake
+ check
+ curl
+ ncurses
+ flex
+ bison
+ gperf
+ gobject-introspection
+ gtk3
+ gtk4
- valgrind
- lcov massif-visualizer
- cppcheck flawfinder
+ # Various libraries
+ openssl.dev
+ zlib.dev
+ curl.dev
+ libconfig
+ czmq
+ libevent.dev
- check
- curl
- ncurses
- flex bison gperf
- gobject-introspection
- gtk3 gtk4
-
- # Various libraries
- openssl.dev zlib.dev curl.dev libconfig
- czmq libevent.dev
-
- # LVGL
- SDL2 libffi.dev
- ]);
- inputsFrom = with pkgs; [ default ];
- meta.platforms = nixpkgs.lib.platforms.linux;
-}
+ # LVGL
+ SDL2
+ libffi.dev
+ ];
+ inputsFrom = with pkgs; [default];
+ meta.platforms = nixpkgs.lib.platforms.linux;
+ }