aboutsummaryrefslogtreecommitdiff
path: root/pkgs/stardict/wrapper.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-01-08 11:25:01 +0100
committerKarel Kočí <cynerd@email.cz>2023-01-08 11:25:01 +0100
commitd5dc7479c489d17e6dcacf081c0f1b5242d99bd9 (patch)
treec12d18231cacb81ff5b69a2073894d228e3c81e7 /pkgs/stardict/wrapper.nix
parentc7a226a92d65cedd384fa29083efdbb07a6084b0 (diff)
downloadnixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.tar.gz
nixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.tar.bz2
nixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.zip
Format using Alejandra
Diffstat (limited to 'pkgs/stardict/wrapper.nix')
-rw-r--r--pkgs/stardict/wrapper.nix36
1 files changed, 20 insertions, 16 deletions
diff --git a/pkgs/stardict/wrapper.nix b/pkgs/stardict/wrapper.nix
index 6547728..e99fa01 100644
--- a/pkgs/stardict/wrapper.nix
+++ b/pkgs/stardict/wrapper.nix
@@ -1,20 +1,23 @@
-{ lib, stdenv, makeBinaryWrapper
-, stardict
+{
+ lib,
+ stdenv,
+ makeBinaryWrapper,
+ stardict,
}:
-
-with stardict;
-
-let
-
- drv = stdenv.mkDerivation rec {
+with stardict; let
+ drv = stdenv.mkDerivation rec {
inherit pname;
inherit version;
inherit meta;
- nativeBuildInputs = [ stardict makeBinaryWrapper ];
- dictionaries = [ /* empty and expecting override */ ];
+ nativeBuildInputs = [stardict makeBinaryWrapper];
+ dictionaries = [
+ /*
+ empty and expecting override
+ */
+ ];
- phases = [ "installPhase" ];
+ phases = ["installPhase"];
installPhase = ''
mkdir -p $out/bin $out/usr/share/stardict/dic
for dic in $dictionaries; do
@@ -32,9 +35,10 @@ let
done
'';
- passthru.withDictionaries = dicts: drv.overrideAttrs (oldAttrs: {
- dictionaries = dicts;
- });
+ passthru.withDictionaries = dicts:
+ drv.overrideAttrs (oldAttrs: {
+ dictionaries = dicts;
+ });
};
-
-in drv
+in
+ drv