aboutsummaryrefslogtreecommitdiff
path: root/pkgs/stardict/glib2.patch
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-06-30 14:32:42 +0200
committerKarel Kočí <cynerd@email.cz>2022-06-30 14:36:49 +0200
commit80372557415a2671584458be4d02cd60bcee0641 (patch)
tree63a362ec0345409c1fc50390c22b8e0d29a1eeae /pkgs/stardict/glib2.patch
parent902f91984818f3ed0ab8b50f95e23aa9b2ab64a0 (diff)
downloadnixos-personal-80372557415a2671584458be4d02cd60bcee0641.tar.gz
nixos-personal-80372557415a2671584458be4d02cd60bcee0641.tar.bz2
nixos-personal-80372557415a2671584458be4d02cd60bcee0641.zip
pkgs/stardict: add stardict itself
It seems to not be able to find translations but I am not using it anyway. I have it just for completeness.
Diffstat (limited to 'pkgs/stardict/glib2.patch')
-rw-r--r--pkgs/stardict/glib2.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/pkgs/stardict/glib2.patch b/pkgs/stardict/glib2.patch
new file mode 100644
index 0000000..bd0f6ba
--- /dev/null
+++ b/pkgs/stardict/glib2.patch
@@ -0,0 +1,36 @@
+diff -Naur old/dict/configure.ac new/dict/configure.ac
+--- old/dict/configure.ac 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/configure.ac 2012-07-12 22:31:52.875176842 +1000
+@@ -266,6 +266,9 @@
+ fi
+ AC_SUBST(WIKI_PARSEDATA_PLUGIN_DIR)
+
++GMODULE2_LIBS=`pkg-config --libs gmodule-2.0`
++AC_SUBST([GMODULE2_LIBS])
++
+ dnl ================================================================
+ dnl main program checks.
+ dnl ================================================================
+diff -Naur old/dict/src/Makefile.am new/dict/src/Makefile.am
+--- old/dict/src/Makefile.am 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/src/Makefile.am 2012-07-12 22:29:53.714870692 +1000
+@@ -33,7 +33,7 @@
+ stardict_DEPENDENCIES = lib/libstardict.la $(LOCAL_SIGCPP_LIBFILE)
+ stardict_LDFLAGS =
+ ## place libstardict.la before any system library, otherwise build with --as-needed linker option may fail
+-stardict_LDADD = lib/libstardict.la $(STARDICT_LIBS) $(LOCAL_SIGCPP_LIBFILE)
++stardict_LDADD = lib/libstardict.la $(STARDICT_LIBS) $(LOCAL_SIGCPP_LIBFILE) $(GMODULE2_LIBS)
+
+ if !GNOME_SUPPORT
+ if MAEMO_SUPPORT
+diff -Naur old/dict/src/tomboykeybinder.h new/dict/src/tomboykeybinder.h
+--- old/dict/src/tomboykeybinder.h 2011-07-03 16:58:40.000000000 +1000
++++ new/dict/src/tomboykeybinder.h 2012-07-12 22:28:04.337920391 +1000
+@@ -21,7 +21,6 @@
+ #ifndef __TOMBOY_KEY_BINDER_H__
+ #define __TOMBOY_KEY_BINDER_H__
+
+-#include <glib.h>
+
+ G_BEGIN_DECLS
+