aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sdcv/wrapper.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-06-30 14:32:42 +0200
committerKarel Kočí <cynerd@email.cz>2022-06-30 14:36:49 +0200
commit80372557415a2671584458be4d02cd60bcee0641 (patch)
tree63a362ec0345409c1fc50390c22b8e0d29a1eeae /pkgs/sdcv/wrapper.nix
parent902f91984818f3ed0ab8b50f95e23aa9b2ab64a0 (diff)
downloadnixos-personal-80372557415a2671584458be4d02cd60bcee0641.tar.gz
nixos-personal-80372557415a2671584458be4d02cd60bcee0641.tar.bz2
nixos-personal-80372557415a2671584458be4d02cd60bcee0641.zip
pkgs/stardict: add stardict itself
It seems to not be able to find translations but I am not using it anyway. I have it just for completeness.
Diffstat (limited to 'pkgs/sdcv/wrapper.nix')
-rw-r--r--pkgs/sdcv/wrapper.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/pkgs/sdcv/wrapper.nix b/pkgs/sdcv/wrapper.nix
deleted file mode 100644
index e26c58c..0000000
--- a/pkgs/sdcv/wrapper.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{ lib, stdenv, makeBinaryWrapper
-, sdcv-unwrapped
-}:
-
-with sdcv-unwrapped;
-
-let
-
- drv = stdenv.mkDerivation rec {
- inherit pname;
- inherit version;
- inherit meta;
-
- nativeBuildInputs = [ sdcv-unwrapped makeBinaryWrapper ];
- dictionaries = [ /* empty and expecting override */ ];
-
- phases = [ "installPhase" ];
- installPhase = ''
- mkdir -p $out/bin $out/usr/share/stardict/dic
- for dic in $dictionaries; do
- for path in "$dic"/usr/share/stardict/dic/*; do
- [ -f "$path" ] || continue
- outln="$out/usr/share/stardict/dic/${"$"}{path##*/}"
- [ -e "$outln" ] && continue
- ln -sf "$path" "$outln"
- done
- done
- makeWrapper ${sdcv-unwrapped}/bin/sdcv $out/bin/sdcv \
- --set STARDICT_DATA_DIR $out/usr/share/stardict/dic
- '';
-
- passthru.withDictionaries = dicts: drv.overrideAttrs (oldAttrs: {
- dictionaries = dicts;
- });
- };
-
-in drv