aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/router.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-06-06 22:11:50 +0200
committerKarel Kočí <cynerd@email.cz>2024-06-06 22:11:50 +0200
commit993a2c5512f7757c45d7ff802065b899cb898b0c (patch)
tree1fd5278c8566270331a9f297d02440f2857d5ced /nixos/modules/router.nix
parente421b3e1543ea63c7ce530332c3371d7a70d03b0 (diff)
downloadnixos-personal-993a2c5512f7757c45d7ff802065b899cb898b0c.tar.gz
nixos-personal-993a2c5512f7757c45d7ff802065b899cb898b0c.tar.bz2
nixos-personal-993a2c5512f7757c45d7ff802065b899cb898b0c.zip
Update and change configuration to fix warnings
Diffstat (limited to 'nixos/modules/router.nix')
-rw-r--r--nixos/modules/router.nix10
1 files changed, 4 insertions, 6 deletions
diff --git a/nixos/modules/router.nix b/nixos/modules/router.nix
index c8b1283..a658515 100644
--- a/nixos/modules/router.nix
+++ b/nixos/modules/router.nix
@@ -98,8 +98,8 @@ in {
matchConfig.Name = "brlan";
networkConfig.VLAN = ["home" "guest"];
bridgeVLANs = [
- {bridgeVLANConfig.VLAN = 1;}
- {bridgeVLANConfig.VLAN = 2;}
+ {VLAN = 1;}
+ {VLAN = 2;}
];
};
"home" = {
@@ -121,10 +121,8 @@ in {
};
dhcpServerStaticLeases =
mapAttrsToList (n: v: {
- dhcpServerStaticLeaseConfig = {
- MACAddress = n;
- Address = v;
- };
+ MACAddress = n;
+ Address = v;
})
cnf.staticLeases;
dhcpPrefixDelegationConfig = {