aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/home-assistant.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-03-24 19:05:39 +0100
committerKarel Kočí <cynerd@email.cz>2024-03-24 19:05:39 +0100
commite84e6dcf117080eaf7658b25fb20a9dc3b5d1cfe (patch)
tree55422d1fc9370dc331fa63125a2df5597310c452 /nixos/modules/home-assistant.nix
parent6c16e4133582def100c39b17369e46906a6d3337 (diff)
downloadnixos-personal-e84e6dcf117080eaf7658b25fb20a9dc3b5d1cfe.tar.gz
nixos-personal-e84e6dcf117080eaf7658b25fb20a9dc3b5d1cfe.tar.bz2
nixos-personal-e84e6dcf117080eaf7658b25fb20a9dc3b5d1cfe.zip
Add wireguard and more updates
Diffstat (limited to 'nixos/modules/home-assistant.nix')
-rw-r--r--nixos/modules/home-assistant.nix20
1 files changed, 8 insertions, 12 deletions
diff --git a/nixos/modules/home-assistant.nix b/nixos/modules/home-assistant.nix
index 267f725..769b1c7 100644
--- a/nixos/modules/home-assistant.nix
+++ b/nixos/modules/home-assistant.nix
@@ -5,13 +5,12 @@
...
}: let
inherit (lib) mkIf mkEnableOption;
- cnf = config.cynerd.home-assistant;
in {
options = {
cynerd.home-assistant = mkEnableOption "Enable Home Assistant and Bigclown";
};
- config = mkIf cnf {
+ config = mkIf config.cynerd.home-assistant {
services.mosquitto = {
enable = true;
listeners = [
@@ -52,16 +51,13 @@ in {
1883 # Mosquitto
];
- services.bigclown = {
- gateway = {
- enable = true;
- device = "/dev/ttyUSB0";
- environmentFile = "/run/secrets/bigclown.env";
- baseTopicPrefix = "bigclown/";
- mqtt = {
- username = "bigclown";
- password = "@PASS_MQTT@";
- };
+ services.bcg = {
+ enable = true;
+ device = "/dev/ttyUSB0";
+ baseTopicPrefix = "bigclown/";
+ mqtt = {
+ username = "bigclown";
+ keyfile = "/run/secrets/mqtt-bigclown.pass";
};
};