aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/home-assistant.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-03-03 20:36:00 +0100
committerKarel Kočí <cynerd@email.cz>2023-03-03 20:36:00 +0100
commitbe12face6349f883eb684906df624956c462342a (patch)
tree10adaf86e58b0f04918dfb581e6239b543e95b68 /nixos/modules/home-assistant.nix
parentfe9594d471fd1ec9531d1adbbee4a407b76252b0 (diff)
downloadnixos-personal-be12face6349f883eb684906df624956c462342a.tar.gz
nixos-personal-be12face6349f883eb684906df624956c462342a.tar.bz2
nixos-personal-be12face6349f883eb684906df624956c462342a.zip
errol: add zigbee2mqtt
Diffstat (limited to 'nixos/modules/home-assistant.nix')
-rw-r--r--nixos/modules/home-assistant.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/nixos/modules/home-assistant.nix b/nixos/modules/home-assistant.nix
index 0aac9be..545cec8 100644
--- a/nixos/modules/home-assistant.nix
+++ b/nixos/modules/home-assistant.nix
@@ -21,21 +21,29 @@ in {
acl = ["readwrite #"];
passwordFile = "/run/secrets/mosquitto.cynerd.pass";
};
- bigclown = {
- acl = ["readwrite bigclown/#"];
- passwordFile = "/run/secrets/mosquitto.bigclown.pass";
- };
telegraf = {
acl = ["read bigclown/node/#"];
passwordFile = "/run/secrets/mosquitto.telegraf.pass";
};
homeassistant = {
acl = [
- "readwrite bigclown/#"
"readwrite homeassistant/#"
+ "readwrite bigclown/#"
+ "readwrite zigbee2mqtt/#"
];
passwordFile = "/run/secrets/mosquitto.homeassistant.pass";
};
+ bigclown = {
+ acl = ["readwrite bigclown/#"];
+ passwordFile = "/run/secrets/mosquitto.bigclown.pass";
+ };
+ zigbee2mqtt = {
+ acl = [
+ "readwrite homeassistant/#"
+ "readwrite zigbee2mqtt/#"
+ ];
+ passwordFile = "/run/secrets/mosquitto.zigbee2mqtt.pass";
+ };
};
}
];
@@ -137,6 +145,7 @@ in {
};
met = {};
default_config = {};
+ automation = "!include automations.yaml";
};
extraComponents = [];
package = pkgs.home-assistant.override {