aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/generic.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-03-14 09:35:13 +0100
committerKarel Kočí <cynerd@email.cz>2024-03-14 09:35:13 +0100
commitb2ec9599373c7e0f5428694c5712c8fc0be06264 (patch)
tree331d4c70ad7664fb9fdbe9ce1050de02e231e6a2 /nixos/modules/generic.nix
parent927fab5c6ec204ce2d7ddac3901519c023331c89 (diff)
downloadnixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.tar.gz
nixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.tar.bz2
nixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.zip
Load of updates and module simplification
Diffstat (limited to 'nixos/modules/generic.nix')
-rw-r--r--nixos/modules/generic.nix10
1 files changed, 8 insertions, 2 deletions
diff --git a/nixos/modules/generic.nix b/nixos/modules/generic.nix
index ea8bd74..5c6e2fe 100644
--- a/nixos/modules/generic.nix
+++ b/nixos/modules/generic.nix
@@ -4,8 +4,9 @@
pkgs,
...
}: let
- inherit (lib) mkOverride mkDefault mkIf optionals;
+ inherit (lib) mkOverride mkDefault optionals;
isNative = config.nixpkgs.hostPlatform == config.nixpkgs.buildPlatform;
+ isArm = config.nixpkgs.hostPlatform.isAarch;
in {
config = {
system.stateVersion = "24.05";
@@ -154,7 +155,12 @@ in {
syntaxHighlighting.enable = isNative;
};
shellrc = true;
- vim.defaultEditor = mkDefault true;
+ vim.defaultEditor = isArm;
+ neovim = {
+ enable = !isArm;
+ defaultEditor = true;
+ withNodeJs = true;
+ };
wireshark.enable = true;
};