aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/generic.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-10-05 22:26:54 +0200
committerKarel Kočí <cynerd@email.cz>2023-10-05 22:26:54 +0200
commit582e5d9959733b2849e3750a41b6aa2547e949e0 (patch)
tree3f41db4a5e35cfba39a42c2d73605d790bfd8945 /nixos/modules/generic.nix
parent8553b18626590e45dbb3a51210e919917632854a (diff)
downloadnixos-personal-582e5d9959733b2849e3750a41b6aa2547e949e0.tar.gz
nixos-personal-582e5d9959733b2849e3750a41b6aa2547e949e0.tar.bz2
nixos-personal-582e5d9959733b2849e3750a41b6aa2547e949e0.zip
Cleanup a bit
Diffstat (limited to 'nixos/modules/generic.nix')
-rw-r--r--nixos/modules/generic.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/nixos/modules/generic.nix b/nixos/modules/generic.nix
index d88618d..8688732 100644
--- a/nixos/modules/generic.nix
+++ b/nixos/modules/generic.nix
@@ -8,7 +8,7 @@ with lib; let
isNative = config.nixpkgs.hostPlatform == config.nixpkgs.buildPlatform;
in {
config = {
- system.stateVersion = "22.05";
+ system.stateVersion = "23.11";
nix = {
extraOptions = "experimental-features = nix-command flakes";
@@ -111,7 +111,7 @@ in {
users.groups.cynerd.gid = 1000;
users.users = {
root = {
- passwordFile = "/run/secrets/root.pass";
+ hashedPasswordFile = "/run/secrets/root.pass";
};
cynerd = {
group = "cynerd";
@@ -135,7 +135,7 @@ in {
if isNative
then pkgs.zsh.out
else pkgs.bash.out;
- passwordFile = "/run/secrets/cynerd.pass";
+ hashedPasswordFile = "/run/secrets/cynerd.pass";
openssh.authorizedKeys.keyFiles = [
(config.personal-secrets + "/unencrypted/git-private.pub")
];