aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/generic.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-06-20 09:33:53 +0200
committerKarel Kočí <cynerd@email.cz>2022-06-20 09:33:53 +0200
commit36a7ff5a0981b0508c0b0647e85ab04b2f3dfbd1 (patch)
treef119d3915d8a96c21d61dbd1a05f3645a252d4ef /nixos/modules/generic.nix
parenta1f70372cb1696f67c6e47bebf0b026145507df5 (diff)
downloadnixos-personal-36a7ff5a0981b0508c0b0647e85ab04b2f3dfbd1.tar.gz
nixos-personal-36a7ff5a0981b0508c0b0647e85ab04b2f3dfbd1.tar.bz2
nixos-personal-36a7ff5a0981b0508c0b0647e85ab04b2f3dfbd1.zip
nixos/modules/generic: add some more tools
Diffstat (limited to 'nixos/modules/generic.nix')
-rw-r--r--nixos/modules/generic.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/nixos/modules/generic.nix b/nixos/modules/generic.nix
index d02cbba..67a80f8 100644
--- a/nixos/modules/generic.nix
+++ b/nixos/modules/generic.nix
@@ -29,9 +29,12 @@ with lib;
environment.systemPackages = with pkgs; [
git # We need git for this repository to even work
# Administration tools
- coreutils moreutils psmisc progress lshw
+ coreutils moreutils psmisc progress lshw file
dig
gnumake
+ exfat exfatprogs
+ nix-index
+ usbutils
# NCurses tools
htop iotop glances
@@ -46,7 +49,7 @@ with lib;
strace
sourceHighlight # Colors for less
- unrar p7zip zip
+ unrar p7zip zip unzip
# Vim plugins (used for root account)
vimPlugins.vim-nix
@@ -70,7 +73,7 @@ with lib;
};
cynerd = {
group = "cynerd";
- extraGroups = ["users" "wheel" "dialout"];
+ extraGroups = ["users" "wheel" "dialout" "kvm" "uucp"];
uid = 1000;
subUidRanges = [{ count = 65534; startUid = 10000; }];
subGidRanges = [{ count = 65534; startGid = 10000; }];