aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/develop.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-08-18 09:59:18 +0200
committerKarel Kočí <cynerd@email.cz>2022-08-18 09:59:18 +0200
commitf15742b86df0be0fa974af5a22265781ba56e675 (patch)
tree97385a71e48e4346db90eba331ea85c9ba1380fd /nixos/modules/develop.nix
parent39cf2de3cc5840c3e7fb448f55dd0b566f2a47d3 (diff)
downloadnixos-personal-f15742b86df0be0fa974af5a22265781ba56e675.tar.gz
nixos-personal-f15742b86df0be0fa974af5a22265781ba56e675.tar.bz2
nixos-personal-f15742b86df0be0fa974af5a22265781ba56e675.zip
nixos/modules: rework interpreted languages development
Diffstat (limited to 'nixos/modules/develop.nix')
-rw-r--r--nixos/modules/develop.nix42
1 files changed, 31 insertions, 11 deletions
diff --git a/nixos/modules/develop.nix b/nixos/modules/develop.nix
index fab5733..310eaa3 100644
--- a/nixos/modules/develop.nix
+++ b/nixos/modules/develop.nix
@@ -36,16 +36,39 @@ in {
jq yq
# Python
- python3 python3Packages.ipython
- twine
- python3Packages.pytest python3Packages.pytest-html #python3Packages.pytest-tap
- python3Packages.coverage
- python3Packages.python-lsp-black
- mypy
- pylint python3Packages.pydocstyle
+ (python3.withPackages (pypkgs: with pypkgs; [
+ ipython
+
+ pytest pytest-html #pytest-tap
+ coverage
+ python-lsp-black
+ pylint pydocstyle
+
+ mypy pygraphviz
+
+ python-gitlab PyGithub
+
+ schema
+ jinja2
+ ruamel-yaml
+ msgpack
+
+ psycopg
+
+ humanize rich
+ #lorem_text
+
+ pyserial pylibftdi
+ selenium
+
+ ]))
+ geckodriver
+ chromedriver
# Lua
- lua51Packages.luacheck
+ (lua5_1.withPackages (luapkgs: with luapkgs; [
+ luacheck
+ ]))
# Ansible
ansible
@@ -71,9 +94,6 @@ in {
# D-Bus
dfeet
- # Bare metal
- openocd
-
# Documentation
man-pages man-pages-posix
];