aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/spt-mox.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-12-14 15:20:26 +0100
committerKarel Kočí <cynerd@email.cz>2022-12-14 15:20:26 +0100
commitc8fce8af5101064ea3dcfcb9d2bc39f1b9b83755 (patch)
tree842dac179e580aafe02526a24ba8982e7ccd713f /nixos/machine/spt-mox.nix
parentc4c0b2a9bfb98250e620c92ac6e173a5946464f7 (diff)
downloadnixos-personal-c8fce8af5101064ea3dcfcb9d2bc39f1b9b83755.tar.gz
nixos-personal-c8fce8af5101064ea3dcfcb9d2bc39f1b9b83755.tar.bz2
nixos-personal-c8fce8af5101064ea3dcfcb9d2bc39f1b9b83755.zip
Add Home Assistant
Now running on Errol as the cross compilation for python cryptography does not work correctly.
Diffstat (limited to 'nixos/machine/spt-mox.nix')
-rw-r--r--nixos/machine/spt-mox.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/nixos/machine/spt-mox.nix b/nixos/machine/spt-mox.nix
index b01c48a..acca74c 100644
--- a/nixos/machine/spt-mox.nix
+++ b/nixos/machine/spt-mox.nix
@@ -75,6 +75,13 @@ with lib;
acl = ["readwrite bigclown/#"];
passwordFile = "/run/secrets/mosquitto.bigclown.pass";
};
+ homeassistant = {
+ acl = [
+ "readwrite bigclown/#"
+ "readwrite homeassistant/#"
+ ];
+ passwordFile = "/run/secrets/mosquitto.homeassistant.pass";
+ };
};
}
];
@@ -170,6 +177,45 @@ with lib;
serviceConfig.ExecStart = "${pkgs.bigclown-leds}/bin/bigclown-leds /run/secrets/bigclown-leds.ini";
};
+ services.home-assistant = {
+ enable = false;
+ openFirewall = true;
+ configDir = "/var/lib/hass";
+ config = {
+ homeassistant = {
+ name = "SPT";
+ latitude = "!secret latitude";
+ longitude = "!secret longitude";
+ elevation = "!secret elevation";
+ time_zone = "Europe/Prague";
+ country = "CZ";
+ };
+ http.server_port = 8808;
+ mqtt = {
+ broker = config.cynerd.hosts.spt.mox;
+ port = 1883;
+ username = "homeassistant";
+ password = "!secret mqtt_password";
+ sensor = import ./hass/sensors.nix;
+ light = import ./hass/light.nix;
+ };
+ met = {};
+ default_config = {};
+ };
+ extraComponents = [];
+ package = pkgs.home-assistant.override {
+ packageOverrides = (self: super: {
+ scapy = super.scapy.override {
+ withPlottingSupport = false;
+ };
+ s3transfer = super.s3transfer.overridePythonAttrs (oldAttrs: {
+ dontUsePytestCheck = true;
+ dontUseSetuptoolsCheck = true;
+ });
+ });
+ };
+ };
+
};
}