aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/gaspode.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-03-14 09:35:13 +0100
committerKarel Kočí <cynerd@email.cz>2024-03-14 09:35:13 +0100
commitb2ec9599373c7e0f5428694c5712c8fc0be06264 (patch)
tree331d4c70ad7664fb9fdbe9ce1050de02e231e6a2 /nixos/machine/gaspode.nix
parent927fab5c6ec204ce2d7ddac3901519c023331c89 (diff)
downloadnixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.tar.gz
nixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.tar.bz2
nixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.zip
Load of updates and module simplification
Diffstat (limited to 'nixos/machine/gaspode.nix')
-rw-r--r--nixos/machine/gaspode.nix30
1 files changed, 11 insertions, 19 deletions
diff --git a/nixos/machine/gaspode.nix b/nixos/machine/gaspode.nix
index cbd08bb..5e57456 100644
--- a/nixos/machine/gaspode.nix
+++ b/nixos/machine/gaspode.nix
@@ -1,23 +1,15 @@
{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib; {
- config = {
- fileSystems = {
- "/" = {
- device = "/dev/mmcblk0p2";
- options = ["compress=lzo" "subvol=@nix"];
- };
- "/home" = {
- device = "/dev/mmcblk0p2";
- options = ["compress=lzo" "subvol=@home"];
- };
- "/boot" = {
- device = "/dev/mmcblk0p1";
- };
+ fileSystems = {
+ "/" = {
+ device = "/dev/mmcblk0p2";
+ options = ["compress=lzo" "subvol=@nix"];
+ };
+ "/home" = {
+ device = "/dev/mmcblk0p2";
+ options = ["compress=lzo" "subvol=@home"];
+ };
+ "/boot" = {
+ device = "/dev/mmcblk0p1";
};
};
}