aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/errol.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-12-14 15:20:26 +0100
committerKarel Kočí <cynerd@email.cz>2022-12-14 15:20:26 +0100
commitc8fce8af5101064ea3dcfcb9d2bc39f1b9b83755 (patch)
tree842dac179e580aafe02526a24ba8982e7ccd713f /nixos/machine/errol.nix
parentc4c0b2a9bfb98250e620c92ac6e173a5946464f7 (diff)
downloadnixos-personal-c8fce8af5101064ea3dcfcb9d2bc39f1b9b83755.tar.gz
nixos-personal-c8fce8af5101064ea3dcfcb9d2bc39f1b9b83755.tar.bz2
nixos-personal-c8fce8af5101064ea3dcfcb9d2bc39f1b9b83755.zip
Add Home Assistant
Now running on Errol as the cross compilation for python cryptography does not work correctly.
Diffstat (limited to 'nixos/machine/errol.nix')
-rw-r--r--nixos/machine/errol.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/nixos/machine/errol.nix b/nixos/machine/errol.nix
index 06e2446..835999a 100644
--- a/nixos/machine/errol.nix
+++ b/nixos/machine/errol.nix
@@ -60,6 +60,34 @@ with lib;
configDir = "/home/cynerd/.config/syncthing";
};
+ services.home-assistant = {
+ enable = true;
+ openFirewall = true;
+ configDir = "/var/lib/hass";
+ config = {
+ homeassistant = {
+ name = "SPT";
+ latitude = "!secret latitude";
+ longitude = "!secret longitude";
+ elevation = "!secret elevation";
+ time_zone = "Europe/Prague";
+ country = "CZ";
+ };
+ http.server_port = 8808;
+ mqtt = {
+ broker = config.cynerd.hosts.spt.mox;
+ port = 1883;
+ username = "homeassistant";
+ password = "!secret mqtt_password";
+ sensor = import ./hass/sensors.nix;
+ light = import ./hass/light.nix;
+ };
+ met = {};
+ default_config = {};
+ };
+ extraComponents = [];
+ };
+
};
}