aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/errol.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-07-29 08:39:20 +0200
committerKarel Kočí <cynerd@email.cz>2022-07-29 08:39:20 +0200
commit7c3d7e4989a83d188a013f9b1a8492f607958b6b (patch)
tree8e73da94323db41f41f0825098f1a3d9a525c808 /nixos/machine/errol.nix
parent0742fe86e3a6210c172d0766ba9f15e5bc3f754f (diff)
downloadnixos-personal-7c3d7e4989a83d188a013f9b1a8492f607958b6b.tar.gz
nixos-personal-7c3d7e4989a83d188a013f9b1a8492f607958b6b.tar.bz2
nixos-personal-7c3d7e4989a83d188a013f9b1a8492f607958b6b.zip
nixos: fix initrd for errol
Diffstat (limited to 'nixos/machine/errol.nix')
-rw-r--r--nixos/machine/errol.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/nixos/machine/errol.nix b/nixos/machine/errol.nix
index 91d6976..5dd87a7 100644
--- a/nixos/machine/errol.nix
+++ b/nixos/machine/errol.nix
@@ -14,6 +14,11 @@ with lib;
};
};
+ boot.initrd.availableKernelModules = ["nvme" "xhci_pci" "usb_storage"];
+ boot.kernelModules = ["kvm-amd"];
+
+ hardware.cpu.amd.updateMicrocode = true;
+
cynerd.autounlock = {
"encroot" = "/dev/disk/by-uuid/c07e929a-6eac-4f99-accf-f7cb3431290c";
"enchdd" = "/dev/disk/by-uuid/7fee3cda-efa0-47cd-8832-fdead9a7e6db";
@@ -21,18 +26,22 @@ with lib;
fileSystems = {
"/" = {
device = "/dev/mapper/encroot";
+ fsType = "btrfs";
options = ["compress=lzo" "subvol=@nix"];
};
"/home" = {
device = "/dev/mapper/encroot";
+ fsType = "btrfs";
options = ["compress=lzo" "subvol=@home"];
};
"/boot" = {
device = "/dev/disk/by-uuid/87B0-A1D5";
+ fsType = "vfat";
};
"/home2" = {
device = "/dev/mapper/enchdd";
+ fsType = "btrfs";
options = ["compress=lzo" "subvol=@home"];
};
};