aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/dean.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-03-14 09:35:13 +0100
committerKarel Kočí <cynerd@email.cz>2024-03-14 09:35:13 +0100
commitb2ec9599373c7e0f5428694c5712c8fc0be06264 (patch)
tree331d4c70ad7664fb9fdbe9ce1050de02e231e6a2 /nixos/machine/dean.nix
parent927fab5c6ec204ce2d7ddac3901519c023331c89 (diff)
downloadnixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.tar.gz
nixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.tar.bz2
nixos-personal-b2ec9599373c7e0f5428694c5712c8fc0be06264.zip
Load of updates and module simplification
Diffstat (limited to 'nixos/machine/dean.nix')
-rw-r--r--nixos/machine/dean.nix68
1 files changed, 30 insertions, 38 deletions
diff --git a/nixos/machine/dean.nix b/nixos/machine/dean.nix
index 906881f..0a97e33 100644
--- a/nixos/machine/dean.nix
+++ b/nixos/machine/dean.nix
@@ -1,46 +1,38 @@
-{
- config,
- lib,
- pkgs,
- ...
-}:
-with lib; {
- config = {
- cynerd = {
- openvpn = {
- oldpersonal = true;
- };
- monitoring.speedtest = true;
+{pkgs, ...}: {
+ cynerd = {
+ openvpn = {
+ oldpersonal = true;
};
+ monitoring.speedtest = true;
+ };
- networking = {
- bridges = {
- brlan = {
- interfaces = [
- "eth0"
- "lan1"
- "lan2"
- "lan3"
- "lan4"
- ];
- };
+ networking = {
+ bridges = {
+ brlan = {
+ interfaces = [
+ "eth0"
+ "lan1"
+ "lan2"
+ "lan3"
+ "lan4"
+ ];
};
- dhcpcd.allowInterfaces = ["brlan"];
};
+ dhcpcd.allowInterfaces = ["brlan"];
+ };
- swapDevices = [
- {
- device = "/var/swap";
- priority = 1;
- }
- ];
+ swapDevices = [
+ {
+ device = "/var/swap";
+ priority = 1;
+ }
+ ];
- environment.systemPackages = with pkgs; [
- #openocd
- tio
- ];
+ environment.systemPackages = with pkgs; [
+ #openocd
+ tio
+ ];
- # TODO: ubootTools build is broken!
- firmware.environment.enable = false;
- };
+ # TODO: ubootTools build is broken!
+ firmware.environment.enable = false;
}