aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/binky.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-03-15 09:13:05 +0100
committerKarel Kočí <cynerd@email.cz>2024-03-15 16:57:21 +0100
commita48d057700c636666a5e835cbcb0b667848008c2 (patch)
tree6e6dc0b9fcf2e85415c2f66b2beb567403be73ca /nixos/machine/binky.nix
parent422ef34e58bc8a187594779d95ef8d74e8332a47 (diff)
downloadnixos-personal-a48d057700c636666a5e835cbcb0b667848008c2.tar.gz
nixos-personal-a48d057700c636666a5e835cbcb0b667848008c2.tar.bz2
nixos-personal-a48d057700c636666a5e835cbcb0b667848008c2.zip
nixos: rework configurations management
Diffstat (limited to 'nixos/machine/binky.nix')
-rw-r--r--nixos/machine/binky.nix70
1 files changed, 0 insertions, 70 deletions
diff --git a/nixos/machine/binky.nix b/nixos/machine/binky.nix
deleted file mode 100644
index 569fccb..0000000
--- a/nixos/machine/binky.nix
+++ /dev/null
@@ -1,70 +0,0 @@
-{lib, ...}: let
- inherit (lib) mkDefault;
-in {
- deploy = {
- enable = true;
- default = false;
- };
-
- cynerd = {
- desktop = {
- enable = true;
- laptop = true;
- };
- wifiClient = true;
- develop = true;
- openvpn = {
- oldpersonal = true;
- elektroline = true;
- };
- };
-
- boot = {
- initrd.availableKernelModules = ["nvme" "xhci_pci" "usb_storage" "sd_mod"];
- kernelModules = ["kvm-amd"];
- };
-
- hardware.cpu.amd.updateMicrocode = true;
-
- boot.initrd.luks.devices = {
- "encroot".device = "/dev/disk/by-uuid/b317feb5-d68d-4ec3-a24f-0307c116cac8";
- };
- fileSystems = {
- "/" = {
- device = "/dev/mapper/encroot";
- fsType = "btrfs";
- options = ["compress=lzo" "subvol=@"];
- };
- "/nix" = {
- device = "/dev/mapper/encroot";
- fsType = "btrfs";
- options = ["compress=lzo" "subvol=@nix"];
- };
- "/home" = {
- device = "/dev/mapper/encroot";
- fsType = "btrfs";
- options = ["compress=lzo" "subvol=@home"];
- };
- "/boot" = {
- device = "/dev/disk/by-uuid/8F7D-A154";
- fsType = "vfat";
- };
- };
- services.btrfs.autoScrub = {
- enable = true;
- fileSystems = ["/"];
- };
-
- services.syncthing = {
- enable = true;
- user = mkDefault "cynerd";
- group = mkDefault "cynerd";
- openDefaultPorts = true;
-
- overrideDevices = false;
- overrideFolders = false;
-
- dataDir = "/home/cynerd";
- configDir = "/home/cynerd/.config/syncthing";
- };
-}