aboutsummaryrefslogtreecommitdiff
path: root/nixos/machine/albert.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-12-20 21:47:46 +0100
committerKarel Kočí <cynerd@email.cz>2022-12-20 21:47:46 +0100
commite09a2f8a23161e52859754e5cf874ec4099a2008 (patch)
tree02601d6f9dee46d6ba92bae44f6e72a1b5f42f0c /nixos/machine/albert.nix
parenta6e7ea6b2d0bca5ae7ef849530905a164bca2b0e (diff)
downloadnixos-personal-e09a2f8a23161e52859754e5cf874ec4099a2008.tar.gz
nixos-personal-e09a2f8a23161e52859754e5cf874ec4099a2008.tar.bz2
nixos-personal-e09a2f8a23161e52859754e5cf874ec4099a2008.zip
nixos: update some machines configuration
Diffstat (limited to 'nixos/machine/albert.nix')
-rw-r--r--nixos/machine/albert.nix19
1 files changed, 18 insertions, 1 deletions
diff --git a/nixos/machine/albert.nix b/nixos/machine/albert.nix
index 0adad68..bc35f96 100644
--- a/nixos/machine/albert.nix
+++ b/nixos/machine/albert.nix
@@ -5,23 +5,40 @@ with lib;
{
config = {
- cynerd.desktop.enable = true;
+ cynerd = {
+ desktop = {
+ enable = true;
+ laptop = true;
+ };
+ wifiClient = true;
+ openvpn = {
+ oldpersonal = true;
+ };
+ };
+
+ boot.initrd.availableKernelModules = ["xhci_pci" "usb_storage" "sd_mod"];
+
+ hardware.cpu.intel.updateMicrocode = true;
fileSystems = {
"/" = {
device = "/dev/disk/by-uuid/1c9bafac-fcf8-41c4-b394-bca5917ca82d";
+ fsType = "btrfs";
options = ["compress=lzo" "subvol=@nix"];
};
"/home" = {
device = "/dev/disk/by-uuid/1c9bafac-fcf8-41c4-b394-bca5917ca82d";
+ fsType = "btrfs";
options = ["compress=lzo" "subvol=@home"];
};
"/boot" = {
device = "/dev/disk/by-uuid/E403-124B";
+ fsType = "vfat";
};
"/home2" = {
device = "/dev/disk/by-uuid/55e177a1-215e-475b-ba9c-771b5fa3f8f0";
+ fsType = "btrfs";
options = ["compress=lzo" "subvol=@home"];
};
};