aboutsummaryrefslogtreecommitdiff
path: root/nixos/configurations/spt-omnia.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2024-03-24 19:05:39 +0100
committerKarel Kočí <cynerd@email.cz>2024-03-24 19:05:39 +0100
commite84e6dcf117080eaf7658b25fb20a9dc3b5d1cfe (patch)
tree55422d1fc9370dc331fa63125a2df5597310c452 /nixos/configurations/spt-omnia.nix
parent6c16e4133582def100c39b17369e46906a6d3337 (diff)
downloadnixos-personal-e84e6dcf117080eaf7658b25fb20a9dc3b5d1cfe.tar.gz
nixos-personal-e84e6dcf117080eaf7658b25fb20a9dc3b5d1cfe.tar.bz2
nixos-personal-e84e6dcf117080eaf7658b25fb20a9dc3b5d1cfe.zip
Add wireguard and more updates
Diffstat (limited to 'nixos/configurations/spt-omnia.nix')
-rw-r--r--nixos/configurations/spt-omnia.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/nixos/configurations/spt-omnia.nix b/nixos/configurations/spt-omnia.nix
index ca4d211..8456368 100644
--- a/nixos/configurations/spt-omnia.nix
+++ b/nixos/configurations/spt-omnia.nix
@@ -37,12 +37,13 @@ in {
channel = 36;
};
};
+ wireguard = true;
openvpn.oldpersonal = true;
monitoring.speedtest = true;
};
services.journald.extraConfig = ''
- SystemMaxUse=512M
+ SystemMaxUse=8G
'';
environment = {
@@ -136,6 +137,7 @@ in {
IPv6AcceptRA = "no";
DHCPPrefixDelegation = "yes";
};
+ dhcpV6Config.PrefixDelegationHint = "::/56";
dhcpPrefixDelegationConfig = {
UplinkInterface = ":self";
SubnetId = 0;
@@ -179,7 +181,7 @@ in {
# TODO limit NSS clamping to just pppoe-wan
networking.firewall.extraForwardRules = ''
tcp flags syn tcp option maxseg size set rt mtu comment "Needed for PPPoE to fix IPv4"
- iifname {"home", "personalvpn"} oifname {"home", "personalvpn"} accept
+ iifname {"home", "personalvpn", "wg"} oifname {"home", "personalvpn", "wg"} accept
'';
services.syncthing = {