aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-01-08 11:25:01 +0100
committerKarel Kočí <cynerd@email.cz>2023-01-08 11:25:01 +0100
commitd5dc7479c489d17e6dcacf081c0f1b5242d99bd9 (patch)
treec12d18231cacb81ff5b69a2073894d228e3c81e7 /flake.nix
parentc7a226a92d65cedd384fa29083efdbb07a6084b0 (diff)
downloadnixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.tar.gz
nixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.tar.bz2
nixos-personal-d5dc7479c489d17e6dcacf081c0f1b5242d99bd9.zip
Format using Alejandra
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix47
1 files changed, 34 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index eb277fa..d1344cc 100644
--- a/flake.nix
+++ b/flake.nix
@@ -17,18 +17,39 @@
usbkey.url = "git+https://git.cynerd.cz/usbkey?ref=modules";
};
- outputs = { self, nixpkgs, nix, nixos-hardware, flake-utils, shellrc, ... }:
+ outputs = {
+ self,
+ nixpkgs,
+ nix,
+ nixos-hardware,
+ flake-utils,
+ shellrc,
+ ...
+ }:
with flake-utils.lib;
- {
- overlays.default = final: prev: import ./pkgs { inherit self; nixpkgs = prev; };
- nixosModules = import ./nixos self;
- nixosConfigurations = import ./nixos/configurations.nix self;
- } // eachDefaultSystem (system: {
- packages = filterPackages system (flattenTree (
- import ./pkgs { inherit self; nixpkgs = nixpkgs.legacyPackages."${system}"; }
- ));
- devShells = filterPackages system
- (import ./devShells { inherit nixpkgs; inherit shellrc; inherit system; });
- });
-
+ {
+ overlays.default = final: prev:
+ import ./pkgs {
+ inherit self;
+ nixpkgs = prev;
+ };
+ nixosModules = import ./nixos self;
+ nixosConfigurations = import ./nixos/configurations.nix self;
+ }
+ // eachDefaultSystem (system: {
+ packages = filterPackages system (flattenTree (
+ import ./pkgs {
+ inherit self;
+ nixpkgs = nixpkgs.legacyPackages."${system}";
+ }
+ ));
+ devShells =
+ filterPackages system
+ (import ./devShells {
+ inherit nixpkgs;
+ inherit shellrc;
+ inherit system;
+ });
+ formatter = nixpkgs.legacyPackages.${system}.alejandra;
+ });
}