aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-09-15 10:08:12 +0200
committerKarel Kočí <cynerd@email.cz>2022-09-15 10:08:12 +0200
commit7b5f6bd95230c4eaac16d3fc2f02365497bd63d7 (patch)
tree6815e7a9492211e79a63a6189373d5616268cfbb /flake.nix
parent929d898bf77ee0d8f8d4f504483369411e2009da (diff)
downloadnixos-personal-7b5f6bd95230c4eaac16d3fc2f02365497bd63d7.tar.gz
nixos-personal-7b5f6bd95230c4eaac16d3fc2f02365497bd63d7.tar.bz2
nixos-personal-7b5f6bd95230c4eaac16d3fc2f02365497bd63d7.zip
Add few packages and allow access to the dhcpcd for wheel
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index 469ebf3..af6346d 100644
--- a/flake.nix
+++ b/flake.nix
@@ -50,6 +50,10 @@
nixturris.nixosModules.turris-crossbuild
nixturris.nixosModules.armv7l-overlay
{ boot.loader.systemd-boot.enable = false; }
+ { nixpkgs.overlays = [ (final: super: {
+ makeModulesClosure = x:
+ super.makeModulesClosure (x // { allowMissing = true; });
+ })]; }
];};
raspi3System = genericSystem {system = "aarch64-linux"; extra_modules = [
nixturris.nixosModules.turris-crossbuild