aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-08-09 09:21:28 +0200
committerKarel Kočí <cynerd@email.cz>2022-08-09 09:21:28 +0200
commit564e6d8b1340d15e1305a072f63eec0378bd7076 (patch)
tree588bdac834ceff71c20e98035bdca1c0454da752 /flake.nix
parent33356ec9bc1a1571491894c6edef73df181f9ac9 (diff)
downloadnixos-personal-564e6d8b1340d15e1305a072f63eec0378bd7076.tar.gz
nixos-personal-564e6d8b1340d15e1305a072f63eec0378bd7076.tar.bz2
nixos-personal-564e6d8b1340d15e1305a072f63eec0378bd7076.zip
Some initial work for Raspberry pi
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix19
1 files changed, 14 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index f4652d2..7af2bb5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -13,7 +13,7 @@
};
outputs = { self
- , nixpkgs, flake-utils
+ , nixpkgs, flake-utils, nixos-hardware
, shellrc, nixturris, personal-secret
, sterm
}:
@@ -45,11 +45,20 @@
};
};
amd64System = genericSystem {system = "x86_64-linux";};
- armv7lSystem = genericSystem {system = "armv7l-linux"; extra_modules = [
+ raspi2System = genericSystem {system = "armv7l-linux"; extra_modules = [
+ nixos-hardware.nixosModules.raspberry-pi-2
nixturris.nixosModules.turris-crossbuild
nixturris.nixosModules.armv7l-overlay
+ { boot.loader.systemd-boot.enable = false; }
+ ];};
+ raspi3System = genericSystem {system = "aarch64-linux"; extra_modules = [
+ ({pkgs, ...}: {
+ boot.loader.systemd-boot.enable = false;
+ boot.loader.grub.enable = false;
+ boot.loader.generic-extlinux-compatible.enable = true;
+ #boot.kernelPackages = pkgs.linuxKernel.packages.linux_rpi3;
+ })
];};
- aarch64System = genericSystem {system = "aarch64-linux";};
turrisSystem = board: hostname: {
${hostname} = nixturris.lib.nixturrisSystem {
@@ -68,8 +77,8 @@
amd64System "lipwig" //
amd64System "ridcully" //
amd64System "susan" //
- armv7lSystem "spt-mpd" //
- aarch64System "adm-mpd" //
+ raspi2System "spt-mpd" //
+ raspi3System "adm-mpd" //
turrisMoxSystem "dean" //
turrisOmniaSystem "spt-omnia" //
turrisMoxSystem "spt-mox" //