aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-08-08 10:13:19 +0200
committerKarel Kočí <cynerd@email.cz>2022-08-08 10:13:19 +0200
commit3649c233b73d03370779a8f58c6613a412979e8b (patch)
treef095d25c9d018802688e4cd56e807093eadd11ac /flake.nix
parent970c8596e86b8bb3ebff5e76e152fa5acdd65f98 (diff)
downloadnixos-personal-3649c233b73d03370779a8f58c6613a412979e8b.tar.gz
nixos-personal-3649c233b73d03370779a8f58c6613a412979e8b.tar.bz2
nixos-personal-3649c233b73d03370779a8f58c6613a412979e8b.zip
Improve devices and few more machines
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index de9c59f..f4652d2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -28,7 +28,6 @@
self.nixosModules.default
self.nixosModules."machine-${hostname}"
shellrc.nixosModules.default
- nixturris.nixosModules.turris-crossbuild
(personal-secret.lib.personalSecrets hostname)
{
networking.hostName = hostname;
@@ -39,15 +38,18 @@
}
];
- genericSystem = system: hostname: {
+ genericSystem = {system, extra_modules ? []}: hostname: {
${hostname} = nixpkgs.lib.nixosSystem {
system = system;
- modules = modules hostname;
+ modules = (modules hostname) ++ extra_modules;
};
};
- amd64System = genericSystem "x86_64-linux";
- armv7lSystem = genericSystem "armv7l-linux";
- aarch64System = genericSystem "aarch64-linux";
+ amd64System = genericSystem {system = "x86_64-linux";};
+ armv7lSystem = genericSystem {system = "armv7l-linux"; extra_modules = [
+ nixturris.nixosModules.turris-crossbuild
+ nixturris.nixosModules.armv7l-overlay
+ ];};
+ aarch64System = genericSystem {system = "aarch64-linux";};
turrisSystem = board: hostname: {
${hostname} = nixturris.lib.nixturrisSystem {