aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-03-23 12:31:51 +0100
committerKarel Kočí <cynerd@email.cz>2023-03-23 12:31:51 +0100
commit2dbccc394a4964a2a3badd192184b6d35dd63336 (patch)
treed11b10501f7f0e520898590969a5c040d6f739f7 /flake.nix
parent28f1ed4a6a1cbf9b32904a010310e3da0f29b81b (diff)
downloadnixos-personal-2dbccc394a4964a2a3badd192184b6d35dd63336.tar.gz
nixos-personal-2dbccc394a4964a2a3badd192184b6d35dd63336.tar.bz2
nixos-personal-2dbccc394a4964a2a3badd192184b6d35dd63336.zip
Rework how I pass packages to the NixOS
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix25
1 files changed, 6 insertions, 19 deletions
diff --git a/flake.nix b/flake.nix
index 730ef12..74defe2 100644
--- a/flake.nix
+++ b/flake.nix
@@ -29,31 +29,18 @@
with flake-utils.lib;
{
lib = import ./lib nixpkgs.lib;
- overlays.default = final: prev:
- import ./pkgs {
- inherit self;
- nixpkgs = prev;
- };
+ overlays.default = final: import ./pkgs;
nixosModules = import ./nixos self;
nixosConfigurations = import ./nixos/configurations.nix self;
}
// eachDefaultSystem (system: let
- pkgs = nixpkgs.legacyPackages."${system}";
+ pkgs = nixpkgs.legacyPackages."${system}".appendOverlays [
+ shellrc.overlays.default
+ ];
in {
- packages = filterPackages system (flattenTree (
- import ./pkgs {
- inherit self;
- nixpkgs = pkgs;
- }
- ));
+ packages = filterPackages system (flattenTree (import ./pkgs pkgs));
legacyPackages = pkgs.extend self.overlays.default;
- devShells =
- filterPackages system
- (import ./devShells {
- inherit nixpkgs;
- inherit shellrc;
- inherit system;
- });
+ devShells = filterPackages system (import ./devShells pkgs);
formatter = pkgs.alejandra;
});
}