aboutsummaryrefslogtreecommitdiff
path: root/devShells/default.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-06-13 08:18:32 +0200
committerKarel Kočí <cynerd@email.cz>2022-06-13 08:18:32 +0200
commit4fa33b32e2567276f84a8ef49cb01328db801fe2 (patch)
treefc000dbb83383660d4090c5f2a1b1659bd168206 /devShells/default.nix
parentef2e9a31c61afdbb106eea365b1758a1c1ceadca (diff)
downloadnixos-personal-4fa33b32e2567276f84a8ef49cb01328db801fe2.tar.gz
nixos-personal-4fa33b32e2567276f84a8ef49cb01328db801fe2.tar.bz2
nixos-personal-4fa33b32e2567276f84a8ef49cb01328db801fe2.zip
devShells/c: add
Diffstat (limited to 'devShells/default.nix')
-rw-r--r--devShells/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/devShells/default.nix b/devShells/default.nix
new file mode 100644
index 0000000..108d6a3
--- /dev/null
+++ b/devShells/default.nix
@@ -0,0 +1,17 @@
+{ nixpkgs, shellrc, system }:
+let
+
+ callDevelop = file: import file {
+ inherit nixpkgs;
+ inherit shellrc;
+ inherit system;
+ };
+
+in {
+
+ armv6 = callDevelop ./nuttx.nix "armv6-m";
+ armv7e = callDevelop ./nuttx.nix "armv7e-m";
+ c = callDevelop ./c.nix;
+ riscv = callDevelop ./riscv.nix;
+
+}