aboutsummaryrefslogtreecommitdiff
path: root/devShells/c.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-06-13 08:18:32 +0200
committerKarel Kočí <cynerd@email.cz>2022-06-13 08:18:32 +0200
commit4fa33b32e2567276f84a8ef49cb01328db801fe2 (patch)
treefc000dbb83383660d4090c5f2a1b1659bd168206 /devShells/c.nix
parentef2e9a31c61afdbb106eea365b1758a1c1ceadca (diff)
downloadnixos-personal-4fa33b32e2567276f84a8ef49cb01328db801fe2.tar.gz
nixos-personal-4fa33b32e2567276f84a8ef49cb01328db801fe2.tar.bz2
nixos-personal-4fa33b32e2567276f84a8ef49cb01328db801fe2.zip
devShells/c: add
Diffstat (limited to 'devShells/c.nix')
-rw-r--r--devShells/c.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/devShells/c.nix b/devShells/c.nix
new file mode 100644
index 0000000..2a16700
--- /dev/null
+++ b/devShells/c.nix
@@ -0,0 +1,18 @@
+{ nixpkgs, shellrc, system }:
+let
+ pkgs = nixpkgs.legacyPackages.${system};
+
+in pkgs.mkShell {
+ packages = (with pkgs; [
+ ccls gcc gdb
+ cppcheck flawfinder bear
+ meson
+ lcov massif-visualizer
+ ]);
+ inputsFrom = with pkgs; [
+ check
+
+ shellrc.packages.${system}.default
+ ];
+ meta.platforms = nixpkgs.lib.platforms.linux;
+}