aboutsummaryrefslogtreecommitdiff
path: root/devShells/apo.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2023-03-03 20:34:08 +0100
committerKarel Kočí <cynerd@email.cz>2023-03-03 20:34:08 +0100
commitfe9594d471fd1ec9531d1adbbee4a407b76252b0 (patch)
tree620fb0fce010a24bb39711844777d0a22f49e2ef /devShells/apo.nix
parent91c066b2f73235f0789ab576be993d1262a990b9 (diff)
downloadnixos-personal-fe9594d471fd1ec9531d1adbbee4a407b76252b0.tar.gz
nixos-personal-fe9594d471fd1ec9531d1adbbee4a407b76252b0.tar.bz2
nixos-personal-fe9594d471fd1ec9531d1adbbee4a407b76252b0.zip
devShells: add apo and tweak qt
Diffstat (limited to 'devShells/apo.nix')
-rw-r--r--devShells/apo.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/devShells/apo.nix b/devShells/apo.nix
new file mode 100644
index 0000000..dd8b772
--- /dev/null
+++ b/devShells/apo.nix
@@ -0,0 +1,34 @@
+{
+ system,
+ nixpkgs,
+ default,
+ c,
+}: let
+ pkgs = nixpkgs.legacyPackages.${system};
+ riscvPkgs = import nixpkgs.outPath {
+ localSystem = system;
+ crossSystem = {
+ config = "riscv32-none-elf";
+ libc = "newlib-nano";
+ gcc = {
+ arch = "rv32i";
+ };
+ };
+ };
+ mipsPkgs = import nixpkgs.outPath {
+ localSystem = system;
+ crossSystem = {
+ config = "mips-none-elf";
+ libc = "newlib-nano";
+ };
+ };
+in
+ pkgs.buildPackages.mkShell {
+ packages = with pkgs; [
+ qtrvsim
+ riscvPkgs.buildPackages.gcc
+ mipsPkgs.buildPackages.gcc
+ ];
+ inputsFrom = [default c];
+ meta.platforms = nixpkgs.lib.platforms.linux;
+ }