summaryrefslogtreecommitdiff
path: root/pkgs/openrc/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/openrc/default.nix')
-rw-r--r--pkgs/openrc/default.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/pkgs/openrc/default.nix b/pkgs/openrc/default.nix
new file mode 100644
index 0000000..8c235e0
--- /dev/null
+++ b/pkgs/openrc/default.nix
@@ -0,0 +1,37 @@
+{ stdenv, lib, fetchgit
+, meson, ninja, pkg-config
+, pam, ncurses
+}:
+
+stdenv.mkDerivation rec {
+ pname = "openrc";
+ version = "0.44.10";
+ meta = with lib; {
+ homepage = "https://github.com/OpenRC/openrc";
+ description = "OpenRC manages the services, startup and shutdown of a host";
+ platforms = with platforms; linux;
+ license = licenses.bsd2;
+ };
+
+ src = fetchgit {
+ url = "https://github.com/OpenRC/openrc.git";
+ rev = version;
+ sha256 = "0azb3ywclzx6cz9bmfpc4aqysz1pq4akr882bvnqh2x78xixcydv";
+ };
+
+ nativeBuildInputs = [ meson ninja pkg-config ];
+ buildInputs = [ pam ncurses ];
+
+ preConfigure = "export DESTDIR=/";
+ mesonFlags = [
+ "-Dbranding=\"NIXOS\""
+ "-Dos=Linux"
+ "-Dselinux=disabled"
+ "-Daudit=disabled"
+ "-Dsysvinit=false"
+ "-Dtermcap=ncurses"
+ "-Dnewnet=true"
+ "-Drootprefix=${placeholder "out"}"
+ "--sysconfdir=${placeholder "out"}/etc"
+ ];
+}