aboutsummaryrefslogtreecommitdiff
path: root/vim/bundle/YouCompleteMe/third_party/pythonfutures/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'vim/bundle/YouCompleteMe/third_party/pythonfutures/setup.py')
m---------vim/bundle/YouCompleteMe0
-rwxr-xr-xvim/bundle/YouCompleteMe/third_party/pythonfutures/setup.py33
2 files changed, 0 insertions, 33 deletions
diff --git a/vim/bundle/YouCompleteMe b/vim/bundle/YouCompleteMe
new file mode 160000
+Subproject 0de1c0c9bb13ce82172b472c676035cd47cf6a6
diff --git a/vim/bundle/YouCompleteMe/third_party/pythonfutures/setup.py b/vim/bundle/YouCompleteMe/third_party/pythonfutures/setup.py
deleted file mode 100755
index c08461e..0000000
--- a/vim/bundle/YouCompleteMe/third_party/pythonfutures/setup.py
+++ /dev/null
@@ -1,33 +0,0 @@
-#!/usr/bin/env python
-import sys
-
-extras = {}
-try:
- from setuptools import setup
- extras['zip_safe'] = False
- if sys.version_info < (2, 6):
- extras['install_requires'] = ['multiprocessing']
-except ImportError:
- from distutils.core import setup
-
-setup(name='futures',
- version='2.1.4',
- description='Backport of the concurrent.futures package from Python 3.2',
- author='Brian Quinlan',
- author_email='brian@sweetapp.com',
- maintainer='Alex Gronholm',
- maintainer_email='alex.gronholm+pypi@nextday.fi',
- url='http://code.google.com/p/pythonfutures',
- download_url='http://pypi.python.org/pypi/futures/',
- packages=['futures', 'concurrent', 'concurrent.futures'],
- license='BSD',
- classifiers=['License :: OSI Approved :: BSD License',
- 'Development Status :: 5 - Production/Stable',
- 'Intended Audience :: Developers',
- 'Programming Language :: Python :: 2.5',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1'],
- **extras
- )