aboutsummaryrefslogtreecommitdiff
path: root/vim/bundle/YouCompleteMe/python/ycm/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'vim/bundle/YouCompleteMe/python/ycm/setup.py')
-rw-r--r--vim/bundle/YouCompleteMe/python/ycm/setup.py53
1 files changed, 53 insertions, 0 deletions
diff --git a/vim/bundle/YouCompleteMe/python/ycm/setup.py b/vim/bundle/YouCompleteMe/python/ycm/setup.py
new file mode 100644
index 0000000..7fc9132
--- /dev/null
+++ b/vim/bundle/YouCompleteMe/python/ycm/setup.py
@@ -0,0 +1,53 @@
+# Copyright (C) 2016 YouCompleteMe contributors
+#
+# This file is part of YouCompleteMe.
+#
+# YouCompleteMe is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# YouCompleteMe is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with YouCompleteMe. If not, see <http://www.gnu.org/licenses/>.
+
+from __future__ import unicode_literals
+from __future__ import print_function
+from __future__ import division
+from __future__ import absolute_import
+# No imports from `future` because when this is loaded, sys.path hasn't been set
+# up yet!
+
+import sys
+import os
+
+# Can't import these from paths.py because that uses `future` imports
+DIR_OF_CURRENT_SCRIPT = os.path.dirname( os.path.abspath( __file__ ) )
+DIR_OF_YCMD = os.path.join( DIR_OF_CURRENT_SCRIPT, '..', '..', 'third_party',
+ 'ycmd' )
+
+
+def SetUpSystemPaths():
+ sys.path.insert( 0, os.path.join( DIR_OF_YCMD ) )
+
+ from ycmd import server_utils as su
+ su.AddNearestThirdPartyFoldersToSysPath( DIR_OF_CURRENT_SCRIPT )
+ # We need to import ycmd's third_party folders as well since we import and
+ # use ycmd code in the client.
+ su.AddNearestThirdPartyFoldersToSysPath( su.__file__ )
+
+
+def SetUpYCM():
+ from ycm import base
+ from ycmd import user_options_store
+ from ycm.youcompleteme import YouCompleteMe
+
+ base.LoadJsonDefaultsIntoVim()
+
+ user_options_store.SetAll( base.BuildServerConf() )
+
+ return YouCompleteMe( user_options_store.GetAll() )