aboutsummaryrefslogtreecommitdiff
path: root/vim/bundle/YouCompleteMe/python/ycm/setup.py
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2016-06-30 16:11:56 +0200
committerKarel Kočí <cynerd@email.cz>2016-06-30 16:11:56 +0200
commit9931e0888b2419326ae10ebbfae532261c5c125f (patch)
tree7504be5daccbb7b7d1ea396754de47b11ed790e5 /vim/bundle/YouCompleteMe/python/ycm/setup.py
parente573b3020c032400eed60b649a2cbf55266e6bb0 (diff)
downloadmyconfigs-9931e0888b2419326ae10ebbfae532261c5c125f.tar.gz
myconfigs-9931e0888b2419326ae10ebbfae532261c5c125f.tar.bz2
myconfigs-9931e0888b2419326ae10ebbfae532261c5c125f.zip
Fix submodules
Diffstat (limited to 'vim/bundle/YouCompleteMe/python/ycm/setup.py')
m---------vim/bundle/YouCompleteMe0
-rw-r--r--vim/bundle/YouCompleteMe/python/ycm/setup.py53
2 files changed, 0 insertions, 53 deletions
diff --git a/vim/bundle/YouCompleteMe b/vim/bundle/YouCompleteMe
new file mode 160000
+Subproject 0de1c0c9bb13ce82172b472c676035cd47cf6a6
diff --git a/vim/bundle/YouCompleteMe/python/ycm/setup.py b/vim/bundle/YouCompleteMe/python/ycm/setup.py
deleted file mode 100644
index 7fc9132..0000000
--- a/vim/bundle/YouCompleteMe/python/ycm/setup.py
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright (C) 2016 YouCompleteMe contributors
-#
-# This file is part of YouCompleteMe.
-#
-# YouCompleteMe is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# YouCompleteMe is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with YouCompleteMe. If not, see <http://www.gnu.org/licenses/>.
-
-from __future__ import unicode_literals
-from __future__ import print_function
-from __future__ import division
-from __future__ import absolute_import
-# No imports from `future` because when this is loaded, sys.path hasn't been set
-# up yet!
-
-import sys
-import os
-
-# Can't import these from paths.py because that uses `future` imports
-DIR_OF_CURRENT_SCRIPT = os.path.dirname( os.path.abspath( __file__ ) )
-DIR_OF_YCMD = os.path.join( DIR_OF_CURRENT_SCRIPT, '..', '..', 'third_party',
- 'ycmd' )
-
-
-def SetUpSystemPaths():
- sys.path.insert( 0, os.path.join( DIR_OF_YCMD ) )
-
- from ycmd import server_utils as su
- su.AddNearestThirdPartyFoldersToSysPath( DIR_OF_CURRENT_SCRIPT )
- # We need to import ycmd's third_party folders as well since we import and
- # use ycmd code in the client.
- su.AddNearestThirdPartyFoldersToSysPath( su.__file__ )
-
-
-def SetUpYCM():
- from ycm import base
- from ycmd import user_options_store
- from ycm.youcompleteme import YouCompleteMe
-
- base.LoadJsonDefaultsIntoVim()
-
- user_options_store.SetAll( base.BuildServerConf() )
-
- return YouCompleteMe( user_options_store.GetAll() )