aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2017-10-04 23:48:37 +0200
committerKarel Kočí <cynerd@email.cz>2018-01-26 17:24:26 +0100
commitc4466a07c446e177dc3104f82e44569f30f04d8a (patch)
tree8fae3197fcebcb21347960d6308ff7b0c759969c /setup.py
downloadlidt-sample-database-master.tar.gz
lidt-sample-database-master.tar.bz2
lidt-sample-database-master.zip
Initial commitHEADmaster
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py28
1 files changed, 28 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..35bd306
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,28 @@
+#!/usr/bin/env python3
+from setuptools import setup
+
+setup(
+ name='lidt-sample-database',
+ version='0.1',
+ description="LIDT sample database",
+ author="Cynerd",
+ author_email="cynerd@email.cz",
+ license="GPLv3",
+
+ classifiers=[
+ 'Development Status :: 3 - Alpha',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ ],
+
+ packages=['lidt-sample-database'],
+ entry_points={
+ 'console_scripts': [
+ 'lidt-sample-database=lidt-sample-database:main'
+ ]
+ }
+ )